Importing GPX files

Forum for questions and problems regarding PathAway GPS 4 SE for Palm OS

Moderator: Scott


Importing GPX files

Postby Guest » Tue Mar 14, 2006 6:07 am

I've been having some difficulty attempting to find information about importing geocache locations/points via GPX files downloaded from (Pocket Queries)

1 - I've downloaded the GPX file, copied it to a folder on my SD memory card, put the SD card into my Zire71.
<b>2 - </b>In Pathaway 4, I choose "Options/Point Databases"
3 - From the "Points" tab menu, I choose "Import". The folder "Browse" screen is displayed. I navigate to the appropriate folder(where the GPX file is located), highlight the GPX file and press the "OK" button.
4 - I immediately receive an "Out of Memory" error. I click "OK" to dismiss the error and receive a "Database Error" - "Error 65535 executing command"

I initially tried importing a GPX file containing 100 Geocaches (GPX file about 600k) & ran into the error, so I decreased the size of the query to only 30 entries (GPX file 210K) and still get the same error.

The GPX file is only 210K in size, and my Zire71 currently has 9.2 Megs of Ram free in main memory, 242 Megs free on the SD card. I'm using Pathaway v4.00.27.

From the Pathaway4 "What's New":
- New Data Import Formats: GPX, LOC Supported via PathAway PC Conversion Tools, or handheld from the new "Import..." option via Database dialogs. Great for GeoCache users.

This was the primary reason I upgraded to PW4. I've searched the manual but there are no references to GPX files in there at all so I'm not sure if the problem is a result my guesses at how to perform the import, or with the program itself.

Any help would be appreciated.


Posts: 8
Joined: Sun Mar 19, 2006 11:16 pm

Postby StuBee » Sun Mar 19, 2006 11:24 pm

I'm currently just demoing Pathaway4..but until an answer comes in, you might want to try the free GPSbabel as a workaround.

It can convert from GPX -> Pathaway, and viceversa: ... p_id=58972

User avatar
Site Admin
Posts: 1033
Joined: Mon Apr 18, 2005 8:49 pm
Location: Ontario, Canada

Postby Scott » Wed Mar 22, 2006 6:14 am

We're working on a fix for this GPX problem. It happens with GPX files with a large amount of text in them. Occurs only on Palm OS devices.

Posts: 80
Joined: Tue Mar 14, 2006 2:54 am
Location: Ontario, Canada

Postby Dodger » Sat Mar 25, 2006 8:59 pm

Thanks Scott. In the meantime, I'm using .LOC files to import my points from They don't contain quite as much info, but it sure beats manually entering the coordinates for hundreds of points.

I'm looking forward to the fix for .GPX files.

Thanks again for the awesome application. It's worth every penny.


User avatar
Posts: 23
Joined: Mon Feb 13, 2006 1:51 pm

Converting files

Postby Minjin » Mon Apr 17, 2006 3:12 am

I don't know if it could help but you can convert files there
Use "GPSBabel" to convert files in PathAway database

I use it and it works fine.

Posts: 80
Joined: Tue Mar 14, 2006 2:54 am
Location: Ontario, Canada

Postby Dodger » Wed Apr 19, 2006 6:02 am

I've done the same - But using GPSBabel only converts the coordinates - It doesn't include the text pages which are included in the GPX file. (Basically the geocaching page associated with each cache) - Nice to have with you in electronic format rather than having to either print them out or switch back & forth between PW and Mobipocket to read the cache info.


Posts: 1
Joined: Sat Jun 10, 2006 6:31 am

Postby bbuhlig » Sat Jun 10, 2006 6:34 am

Any movement on this bug? I just bought Pathaway and quickly ran into it, which pretty severely limits for me the program's usefulness for me as an aviation moving map/waypoint GPS app.

Posts: 10
Joined: Mon Jul 24, 2006 3:55 pm
Location: Ontario, Canada

importing GPX files with Windows Mobile

Postby wareed » Mon Jul 24, 2006 4:07 pm

Running PathAway on my Dell Axim X51 (Windows Mobile) I also have problems importing the .GPX files that I've downloaded from In my case, the import truncates the cache identfiers to five characters. While I've downloaded the gpxbabel software and it works fine to convert from .GPX to .LOC, ideally I don't want to be relying on a desktop or notebook PC other than to grab the downloads from Is there a setting I'm missing that would ensure the import gets all six characters of the cache identifiers in a .GPX file? Or is this a known issue?

Return to “PathAway GPS 4 SE for Palm OS - Support”

Who is online

Users browsing this forum: Google [Bot] and 5 guests