Page 1 of 1

Unable to import GPS track created in another application

Posted: Sat Nov 12, 2011 9:36 pm
by TwelveSticks
I have a problem when trying to import a GPS track that was created in another application (namely QSports). I have tried to import the track as a GPX file, a KML file and as a Zip file (containing the GPX file). In all cases, as soon as I click on the 'Start Import' button, PathAway disappears off the screen and needs to be restarted. The track is not imported.

Some points:

1. I have tried sending the tracks in e-mails, and also transferring them using iTunes. The results are always the same. PathAway can see the files, it just cannot import them.

2. The KML version opens fine in Google Earth, so I trust it is formatted correctly.

3. I have successfully imported GPX files that were created on another iPhone (using PathAway) before so the import mechanism itself is not the problem.

It would seem that something about the files that are being created by QSports (be it GPX or KML) are causing PathAway to crash.

Any ideas???

I have attached the GPX file in question...

Posted: Sat Nov 12, 2011 11:30 pm
by TwelveSticks
Quick update on this:

I found that I could import my KML into another iPhone/iPad app (Walkmeter) and then export it back out of there as another KML file. This 2nd version will then import into PathAway without problem.

So... It would seem to confirm my suspicion that PathAway cannot deal with the files being output from QSports, even though other apps can.

Although I have found a workaround for this problem, it really isn't very satisfactory to have to go to all that trouble to import simple files. Maybe PathAway can sort is out in a future upgrade?

Posted: Fri Jan 20, 2012 12:43 am
by Scott
Can you post a sample file that is not working?
Or send it to me via private message.

Posted: Sat Feb 25, 2012 8:11 pm
by TwelveSticks

Only just seen your reply - I have attached a sample KML file.

This file can be opened without problem in other applications, e.g. Google Earth, but cannot be imported into PathAway on iPad or iPhone.

Hope you can help!



Posted: Thu Mar 01, 2012 8:06 am
by Scott
The problem with your KML file is fixed now. We've also made a few performance improvements for large track files.

You can try the pre-release out at

Posted: Thu Mar 01, 2012 2:34 pm
by TwelveSticks

But do you have a new version for iOS? I'm only interested in the iPhone and iPad versions...

Posted: Thu Mar 01, 2012 4:31 pm
by Scott
Oops. Sorry about that. The iOS version is fixed as well. This build will be posted to iTunes store soon but will take a few days for it to show up.
If you want to become a Beta tester and get the build to test sooner, then please contact us via and we'll provide instructions.

Note, until then, the work-around for these kml files is to remove the encoding data at the beginning of the file. This data is not needed because the header specifies the encoding. This the first 3 characters of the file. You might need a binary editor to do this. Or open and save the file in ANSI/Western/Latin format or UTF-8 without BOM.

Posted: Thu Mar 08, 2012 10:51 pm
by natpuk